Equipviewer Unexpected Symbol Near '<'

Language: JP EN DE FR
New Items
2019-12-13
609 users online
Forum » Windower » Support » Equipviewer unexpected symbol near '<'
Equipviewer unexpected symbol near '<'
Offline
Posts: 7
By Beastaru 2020-01-12 10:13:06
Link | Quote | Reply
 
I have done the procedure 3 times to assure I didn't do anything stupid. For whatever reason I continue to get - equipviewer: lua syntax error: equipviewer/equipviewer.lua:7 unexpected symbol near '<'

I have made sure I am getting the correct script (windower not ashita) and I am still coming up with this error.

I have been trying to find where someone had a similar issue, they posted that someone on here let them copy their script from lua core file and it fixed their issue but did not give a link to that post. It seems the one from the site are no longer 100% working as that's where I've copied mine from and he did as well?

Anyone know of this issue or how to resolve it? thanks in advance!

-Beastaru
 Asura.Nebohh
Offline
Server: Asura
Game: FFXI
user: Kealohaa
Posts: 70
By Asura.Nebohh 2020-01-12 10:33:31
Link | Quote | Reply
 
It’s usually something that simple and exactly what it says. And yeah a screenshot would help. Plus post that lua along with line 7 and few lines before and after.
By Jetackuu 2020-01-12 10:50:26
Link | Quote | Reply
 
Sounds like you downloaded the html of the file and not the file itself, download raw.

Lern2git.

Gitgud.

#puns.
[+]
Offline
Posts: 7
By Beastaru 2020-01-12 11:11:45
Link | Quote | Reply
 


That's the error I receive.



Here's the code I got from the original site. I am assuming line 7 is literally the 7th line down. I don't see any weird symbols that would be out of the ordinary? Admittedly not a programmer so my HTML is very limited.
Offline
Posts: 7
By Beastaru 2020-01-12 11:15:20
Link | Quote | Reply
 
I specifically saved the file that was on the site provided here: https://github.com/ProjectTako/ffxi-addons/tree/master/equipviewer


I did not copy/paste anything, saved as instructed per the post directions.
Offline
Posts: 6098
By Pantafernando 2020-01-12 11:18:32
Link | Quote | Reply
 
Is that equipviewer the one addon from project tako?

If its the addon, normally addon need to declare author etc before starting meaning you got the wrong file, like jectacku said:

Quote:
_addon.name = 'EquipViewer';

_addon.version = '1.0';

_addon.author = 'Project Tako';

You can just open a new folder in addon folder, name it "Equipviewer" then copy paste entire script in an .lua archive.
Offline
Posts: 7
By Beastaru 2020-01-12 11:22:42
Link | Quote | Reply
 
okay, I'll try that. I figured it's something stupid that I did...

Thank you all
By Jetackuu 2020-01-12 11:23:41
Link | Quote | Reply
 
Beastaru said: »
I
You did exactly as I described, remedy as directed. Or copy/pasta the lua into a blank file, save as filename.lua under "all file types."

Lern2git.

Gitgud.

#puns.
[+]
By Jetackuu 2020-01-12 11:26:06
Link | Quote | Reply
 
tl;dr you have to save the "raw" not the file, blame git. /shrug
[+]
Offline
Posts: 7
By Beastaru 2020-01-12 11:32:28
Link | Quote | Reply
 
I got you. I messed up, I thought I did it as it was posted but clearly I was mistaken. I'm trying it now, ty.
[+]
By Jetackuu 2020-01-12 11:36:21
Link | Quote | Reply
 
Honestly I don't know why they make it so complicated, it's silly.
Offline
Posts: 7
By Beastaru 2020-01-12 11:39:20
Link | Quote | Reply
 
The process of adding the addon does seem needlessly convoluted but it looks like an extremely helpful addition. I'm coming back after a few year break so I am extremely rusty in the setup process, let alone catching back up on the game itself.

I appreciate everyone's help
[+]
Offline
Posts: 7
By Beastaru 2020-01-12 11:48:32
Link | Quote | Reply
 
It's up and working. I had completely jacked it up from the get go. Thank you jet for kind of laying it out for me. That was actually super helpful.
[+]
 Bismarck.Xurion
Offline
Server: Bismarck
Game: FFXI
user: Xurion
Posts: 337
By Bismarck.Xurion 2020-01-13 04:02:57
Link | Quote | Reply
 
Beastaru said: »
The process of adding the addon does seem needlessly convoluted
It's more to do with the different systems having their quirks, such as Github raw etc. That and if you're adding an unofficial addon, you have to jump through manual hoops that can result in human error. We've all typo'd the directory or lua file name incorrectly and it's taken us a good 5 mins to figure out why it doesn't work.

With that in mind, is there a reason why EquipViewer was never added to official Windower? The icon count?
Offline
Posts: 6098
By Pantafernando 2020-01-13 04:24:09
Link | Quote | Reply
 
The process to "main" some addons involves the author submiting to windower, that will do their checkings and publish it (or no).

So either the author isnt interested in publishing his addon on main launcher or windower saw something it could have any risk.
 Asura.Chiaia
VIP
Offline
Server: Asura
Game: FFXI
user: Demmis
Posts: 1080
By Asura.Chiaia 2020-01-13 04:29:41
Link | Quote | Reply
 
Was never submitted to us. Normally wouldn't bother commenting about x addon not being submitted to us but this one I know a lot of people would love to see on the launcher.
 Bismarck.Xurion
Offline
Server: Bismarck
Game: FFXI
user: Xurion
Posts: 337
By Bismarck.Xurion 2020-01-13 08:35:15
Link | Quote | Reply
 
EquipViewer has a total of 56,748 icons across 16, 32, 48 and 64 size totalling over 200mb. If EquipViewer was submitted, would you guys be ok with the initial download, or would you look towards a solution where the icons needed to be installed manually for each user?
[+]
Log in to post.